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Using Designer Tool 
 
Designer Tool is used to create templates for reports accessed through MarketLinx suite of MLS 

applications. Designer Tool is a stand-alone program that must be first downloaded to a PC with 

internet access before it can be used.  

 

In this workbook, you will learn: 

Å Logging In  

Å Designer Tool Overview  

Å Creating New Reports  

Å Editing Existing Reports 
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Logging In 
After downloading Designer tool  double click the                icon on your desktop to login or 

click on Start--Programs--Designer Tool if you do not see the icon. You must have an internet 

session running in the background. When logging in you will have the option to save your ID 

and Password for future sessions.  

To Start Designer Tool and Log In 
1 Double-click the Designer Tool icon to start. The Designer Tool 

Login dialog box appears. 

 
 

2 Enter your MLS Login ID and Password. 

3 Click the OK button. The following Designer Tool dialog box appears. 

 
4 Select an existing report or create a new one and click the OK 

button. 

ï For information on creating a new report, see pages 5-15. 

ï For information on editing an existing report, see pages 16-17. 

Click here to save your password. 
The next time you log in, you wonôt 
need to enter it. 
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Designer Tool Overview 
  
Types of Reports 
Create your own report format based on one of the following report types: 

Multiple Ro w . One or more horizontal records per page. Includes page header and footer. 

Multiple Columns . One or more vertical records per page. Includes page header and footer, 

and row header. 

Flyer. Single record per page. This option also covers the usual, single property per page 

listing format. 

Tabular . One or more horizontal records per page. Includes report header, page head, page 

footer, and report footer. 

Labels. One or more horizontal and vertical records per page. 

Marketing Booklet . One or more horizontal and vertical records per page. Includes page 

header and footer. 

Statistical. One or more horizontal and vertical records per page. Includes report header, page 

header, group headers, group footers, and page footer, and report footer. 

 

Workspace 
Itôs easy to add fields and elements in the workspace. Just click, drag, 

and drop the fields from the Drag and Drop Fields box. You can also 

select an element, such as lines & frames, and drop them into the workspace. 
 
 

The Insert 
menu 
shows 
elements 
you can 
insert in 
your 
report. 

 

Workspace is 
where all your 
information 
goes. 

 

Drag and  

Drop Fields 

List shows 

Data Fields 

available  for 

the specified 

Data 

Source/Type 

Select Data Type Choose the source 

of the Data to be used in the report 
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Creating New Reports 
Before creating a report in Designer Tool, you may want to sketch it 

out on paper to see how you want it to look and which elements you 

want to use. 

 
 
 
 
 

Report A Created using Designer Tool 

Draft of Report A 

Before Designer  Tool 
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To Create a New Report 
In this section, you will learn how to insert and place different elements 

in a one-page flyer. The method to create any report is the same. 

1 Click the New Report icon (or click the File menu and select 

New). The New Report wizard appears. 

 

 
Click Next 

 

2 Select a Data Type and click the Next button. The Report Format 

Selection screen appears. 

3 Select Report Type as Flyer. 
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               Select Flyer             Click Next 
 

4 Click the Next button. The New Report wizard screen appears. 

 
           Click Finish 

5 Click the Finish button. The Designer Tool Workspace appears. 

From here, you will insert new fields as shown on the following 

pages. 
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Donôt forget to consult your sketch as you use the Designer Tool. Start from the top and work your way down. 
 

Insert and Format a Frame 

1 Click the Frame icon (or click the Insert menu and select Frame). 

The Insert Frame dialog box appears. 
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2 Select the frame properties. 

3 Click the OK button to insert the frame into the report. The 

insertion cursor appears (arrow with square). 

4 Drop the frame in the workspace. 

 
 
 

 
 

To size a 

selected 

object, move 

the cursor to 

the corner 

border until it 

changes to an 

arrow. Hold 

the left mouse 

button-down 

and drag the 

mouse to the 

new size. 
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Insert and Format Text 

1 Click the  Text icon (or click the Insert menu and select Text). The 

Insert Text dialog box appears. 

 
2 Enter the text in the Text box. The text appears in the Sample box. 

3 Select the text properties. 

ï To enter a border around the text, click the Border tab. 

ï To make the text a hyperlink, click the Hyperlink tab. 

4 Click the OK button to insert the text into the report. The insertion 

cursor appears (arrow with letter A). 

5 Drop the text in the workspace. 

 

Text Box 

Sample Box 

To move a 
selected object, 
move the cursor 
over the 
object until it 
changes to 
a double arrow. 
Drag the 
object to its new 
location. 
To align objects, 
hold down 
the CTRL key 
and click 
each object. 
Click the 
Align menu and 
select an 
option. 
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Insert and Format a Picture 

1 Click the  Picture icon (or click the Insert menu and select 

Picture). The Insert Picture dialog box appears. 

 

 

 

 

 

 

 
 

 

 

 

 

 

 

2 Select the image properties. 

ï To enter a border around the image, click the Border tab. 

ï To make the image a hyperlink, click the Hyperlink tab. 

3 Click the OK button to insert the picture into the report. The 

insertion cursor appears (arrow with camera). 

4 Drop the picture in the workspace. 
Note: The picture appears as a shaded square. 

Standard Property Image ï Used to 
specify which of the numerically stored 
multiple property images will be inserted 
into the report 
MLS Passport Special Image ï Used to 
specify which of the  saved special images 
such as subject property  photo will be 
used on the report 
Other Local Image ï  Used to specify an 
image that is stored on the PC that  is 
being used to print the report 
Named Property Image ï  Used to specify 
an image to be used on a report by the 
image title and not the image numeric 
position 
Submitted MLS Image ï  Used to specify  
previously stored (by MLS Staff) images 
such as equal housing , Realtor, etc. to be 
used in a report 
Submitted Office Image ï  
Used to specify  previously stored (by 
Office Staff) images such as company logo 
to be used in a report 
 
Submitted Agent  Image - 
Used to specify  previously stored (by the 
logged in agent) images such as agent 
photos to be used in a report 
 

 



Designer Tool Page 12 
 

Insert a Map 
1. Click the Insert menu and select Map. 

2. Click and drag the area that the map will assume on your report. Let go of the left mouse 

button, the area that map will assume is represented by a shaded square. 

3.  If needed further adjust the dimensions of the map by clicking the edges and dragging to 

increase or reduce the objects overall size. 
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Insert a Phrase 
1 Click the Insert menu and select Phrase. The Insert Phrase dialog 

box appears. 

 

 
 

You can only select one phrase at a time. 
2 Select a phrase. 

3 Click the OK button to insert the phrase into the report. The 

insertion cursor appears (arrow with letter A). 

4 Drop the phrase in the workspace. 

 

 

Note: The following applies 
to any field added containing 
text. 
 
The text will take on the 
properties of the last text you 
entered.  
 
To change the properties of a 
text field, double click the 
phrase and use the options 
provided in the Edit Text 
dialog box that appears. 
Simple modifications can 
also be made using the  font 
edit options located on the 
menu bar. 
 
To delete an object, select it 
and press the 
Delete key.  
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Insert and Format a Data Field 
The Drag and Drop Fields box is an easy way to insert a data field in 

the workspace.  

Note: You can also click the Data Field icon (or click the 

Insert option from the menu  bar and select Data Field). 

1 Drag a data field from the Drag and Drop Fields box and drop it in 

the workspace. To select more than one field, hold down the CTRL key and click the name of 

each field. Hold the CTRL key as you drag. To select a range of fields, click the name of the first 

field in the range. Hold down the SHIFT key and click the name of the last field. Hold the CTRL 

key as you drag. 

 
 

 

 

 

 

 

Click here to include the accompanying label for the Data 
Field before dragging the field to the workspace.  

 

Drag & Drop 
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2 Double-click the data field to edit the properties. The Edit Data 

Field dialog box appears. 

 
 
 

3 Select the data field properties. 

ï To change the font, click the Font tab. 

ï To enter a border around the data field, click the Border tab. 

ï To make the data field a hyperlink, click the Hyperlink tab. 

4 Click the OK button 

Insert and Format a Statistical Field 

1 Use the  Icon (from the 

menu bar) to insert the data fields 

that will be used in your 

statistical calculation (e.g. to 

calculate price per square foot 

you must insert the field for price 

and the field for square footage 

together for Sale Price Ratio you 

must insert List and Sale price). 

 

2 Use the Arithmetic pull down 

menu to select which 

mathematical calculation will be 

Note:  
If you selected 
more than one 
data field, they 
are considered 
interconnected. 
They all appear 
here and the 
Data Field 
properties apply 
to all of them. 
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applied to the values  of the data fields in the ñSelected Data Fieldsò box. 

Note: The order of the selected data fields and which one  is highlighted determines what 

calculations are available that calculation is applied.  

3 Assign a Prefix or Suffix if necessary  

4 Click OK 

 

To display the average, median, max, min or summation of a stat:  

Note: This is helpful when creating a report that will display multiple properties at once and/or  creating a CMA 

report with statistical data 

1 Select a previously defined arithmetic field from the Drag and 

Drop Fields box. 

2 Click the Insert menu and select 

Statistic. The Insert Statistic 

dialog box appears. 

3 Select the type of statistic to calculate 

from the Statistical 

Operation column. 

4 Select the numerical data field from 

the Available Arithmetic Data 

Fields column. The Arithmetic Formula 

appears. 

5 Click the OK button to insert the 

Statistic into the report. The 

insertion cursor appears. 

6 Drop the statistic in the workspace. 

 

First, select type of statistic.  
 
Second, select the data field that can be used to calculate statistic. 
 
Third, view the arithmetic formula. 
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To Save a Report 

1 Click the Save icon or click File and select Save Report. 

The Save Report dialog box appears. 

 
2 Enter the Report Name. The Description is optional. 

3 Click the Save button. The Report is now saved and available in your MLS system under your 

login. 
Note: if you are logged in as the broker or office admin and saved  the report for the office, the entire office will 

have access to that report. 

 

To View a Report in Your MLS system 

Login to the MLS and navigate to the detail screen of a listing, from the list of available reports 

select the newly created Designer Tool report. 
Note: While there is a preview option available within Designer Tool the best representation of what the report will 

look like when printed as well as what needs to be corrected before printing is obtain by actually navigating your 

MLS to a listing and viewing it with live data. 



Designer Tool Page 18 
 

 

Editing Existing Reports 
There are many system report types for you to choose from. If you find 

one that suits your needs, you can use it as is or copy it to a new file 

name and edit it. In this section, you will learn how to edit an existing 

Flyer. 

To Edit an Existing Report 
1 Click the Open icon (click the File menu and select Open). The 

Open Report dialog box appears. 

 
2 Select the file you want to view and click the Open button. The 

report appears in the workspace. 

3 Click the File menu and select Save Report As. The Save Report 

As dialog box appears. 

4 Enter the Report Name. The Description is 

optional. 

5 Select the Information Type . The 

selection here determines which 

data fields you can select from. 
 

6 Click the Save button. The Report is saved 

and you can edit it, as 

shown on the next page. 

You can sort 
by 
information 
(listing 
type) or by 
style 
(report type) or 
both. 

 



Designer Tool Page 19 
 

 
7 Double-click on any object to edit it. The Edit dialog box appears. 

 
8 Update the properties as needed and click the OK button. 

9 When you are done editing the report, click the Save icon (click the 

File menu and select Save Report). 




